Honda Rebel 300 & 500 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
A few days ago my girlfriend pointed out that my left running light on the front was out, and after a test it seemed that while the running light was in fact not working, there wasn't an issue with the indicator. My first thought was that someone had knocked my front indicator and somehow damaged the wire responsible for the running light, but before getting too deep into things I thought it best to check the simplest thing: the bulb.

While the bulb itself seems to be fine there is some pretty clear corrosion/rust not only on the base of the bulb, but inside the socket as well. Clearly some amount of moisture has been making its way into the indicator housing. Has anyone experienced this with the stock indicators? The connection point between the indicator housings on both the front and back seems to have quite a gap where moisture could get it, and after some futsing with the connection I was able to make it less pronounced.

You can (hopefully) see in the photo that the rust doesn't look too bad, and I think it should be possible to clean it up.
 

Attachments

·
Registered
Joined
·
1,328 Posts
Get a tube of Dielectric Grease and apply a thin coat of grease on the fittings that are rusty, before applying the grease clean up the rust with ScotchBrite or steel wool.
I have no signs of rust on the turn signals on my Rebel, but in the past I have used black silicone caulk or sealer to seal up an electric area that water getting in was a problem for me.

Kenny G
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Get a tube of Dielectric Grease and apply a thin coat of grease on the fittings that are rusty, before applying the grease clean up the rust with ScotchBrite or steel wool.
I have no signs of rust on the turn signals on my Rebel, but in the past I have used black silicone caulk or sealer to seal up an electric area that water getting in was a problem for me.

Kenny G

All good steps. That should help me get this cleaned up. The caulk is a good call too.


Also have you checked the bulb? Dual filament bulb on front due to the DRL's so worth a check......
Both filaments look to be intact, but I'll do a quick test once I've cleaned the rust off of the base left bulb by trying it in the right indicator.
 
1 - 4 of 4 Posts
Top