Honda Rebel 300 & 500 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
428 Posts
Discussion Starter #1
So my front turn signals have been dead due to some manufacture defect, the company said they'd replace it then proceeded to blow me off and ignore all my attempts to contact them for the next two months orrrrr the guy died or something and in that case I'd feel bad for saying this but DON'T EVER BUY FROM HIGHSPEEDTECH.COM !!!!!!! I'm a pretty calm person when it comes to retail mistakes because I worked retail for a long time and 99% of the time it's not the employees fault. but seriously 2 months, 8 voicemails and 3 emails to no reply is ridiculous, he has to be dead right?

Today was the last straw though, i ordered some new turn signals, however they have 2 wires instead of 3 like the harness has. My question is do i splice both the running light wire and the turn signal wire from the bike to the power wire on the light? and of course ground to ground.

here is a diagram they included and it looks like that would be the correct way but i just want to confirm through someone on here thats how you do it.

any help would be great thank you!

here are the lights i ordered if you're interested they should look pretty cool. https://www.revzilla.com/motorcycle/joker-machine-led-rat-eye-front-fork-turn-signals
 

Attachments

·
Registered
Joined
·
25 Posts
That's pretty nifty. All I did was connect the turn signal and running lights and use 2 diodes (to prevent bidirectional flow). Don't forget to use an LED relay as well.
 
1 - 3 of 3 Posts
Top