Honda Rebel 300 & 500 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Just a warning about the side covers. A few days ago I noticed that my left sidecover is "unhinged" at the front and wobbly. So, I snapped it back in, and kept any eye on it.
Went out riding on Saturday, and after I got home, I realized that the right sidecover has flown off completely. After looking at the rubber housing that's supposed to hold it in place, it looks like it's all pushed into the slot. Since I haven't taken them off since I got the bike, I am guessing they might be installed sloppily at the factory. So, keep an eye out and make sure yours is nice and tight.
 

·
Registered
Joined
·
1,328 Posts
Mr M,

Put a dab of wax or lubricant on the posts that stick out of the side covers, and then when you push the covers on the rubber holders they will seat properly.

Kenny G
 

·
Super Moderator
Joined
·
1,233 Posts
I've heard of people losing their side covers enough to think it's a problem needing a solution. Perhaps there is a way to drill one or more mounting posts and clip it behind the grommet.
 

·
Super Moderator
Joined
·
979 Posts
The grommet needs to be seated correctly before pushing the cover back on, but if you force the cover back on without checking the alignment the grommet will deform again.

As Kenny mentioned, some lubricant prob would help to seat the peg smoothly.
 

·
Super Moderator
Joined
·
1,655 Posts
Yeah it might just be some sloppy work from the factory, one of mine rubber thingies was also squeezed all the way in, not holding onto the side cover properly.
 
1 - 7 of 7 Posts
Top