Honda Rebel 300 & 500 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
136 Posts
Discussion Starter #1
I keep having issues where my left trim cover falls off while riding and I have to order a new one. I have a third one now and my dealership said that they have seen this issue with several Rebel 5s. I cannot get the piece to hold towards the headlight. It is really frustrating and I am curious if anyone has the same issue and has figured out what is happening. In the meantime, I am going to throw a cotter pin on it.
 

·
Registered
Joined
·
712 Posts
The rubber grommet where the front tab seats gets pushed in some times.

Make sure it's not pushed in before replacing the cover.

You should also hear and feel a distinct "click" when each of the pins and tab seats to indicate that it's properly fitted.
 

·
Registered
Joined
·
1,328 Posts
I keep having issues where my left trim cover falls off while riding and I have to order a new one. I have a third one now and my dealership said that they have seen this issue with several Rebel 5s. I cannot get the piece to hold towards the headlight. It is really frustrating and I am curious if anyone has the same issue and has figured out what is happening. In the meantime, I am going to throw a cotter pin on it.
After you are sure that the rubber grommet is properly seated put just a little bit of wax, or any lubricant, on the pins before seating the cover.

Kenny G
 

·
Registered
Joined
·
136 Posts
Discussion Starter #4
I used lithium grease and it never clicks. I lost a trim panel to trying to push too hard and it broke the tab. The grommet seams flush and in properly.

Sent from my Pixel 2 XL using Tapatalk
 

·
Registered
Joined
·
1,328 Posts
I used lithium grease and it never clicks. I lost a trim panel to trying to push too hard and it broke the tab. The grommet seams flush and in properly.

Sent from my Pixel 2 XL using Tapatalk
Make sure there is not a wire interfering with the cover seating.

Good luck.

Kenny G
 

·
Registered
Joined
·
136 Posts
Discussion Starter #8
I had the main harness in the way, but it wouldn't budge. I just pressed the panel with a lot of force and it went in right. Finally. The whole falls off and wait weeks for a replacement dance has been old the last several months. Thanks y'all.

Sent from my Pixel 2 XL using Tapatalk
 
1 - 8 of 8 Posts
Top