Honda Rebel 300 & 500 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey, all.

First-time motorcycle owner here. I've had a Rebel 500 since June. Love it. Already put more than 3,000 miles on the thing.

My turn indicator lights have been functioning normally, and then I come out of work the other day and the front right signal won't turn OFF. It's constantly solid. I click over to indicate a turn and it blinks as normal -- on off on off. When I cancel the turn, the light doesn't turn off, it goes back to solid.

The other lights on the bike appear to be functioning correctly.

Anyway, I'm trying to learn how to fix the motorcycle (first regular oil change coming up soon) and hope I can deal with this on my own.

Appreciate the help in advance. Thanks, all.
 

·
Registered
Joined
·
173 Posts
Both of your front turn signals should also be acting as running lights. So if your left and right aren't both on when running then your left running light isn't working.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
306 Posts
When you turn your ignition on, both front turn signals should be continuously lit.

When you indicate right (for example), power to the right running light wire is cut and power is sent to the right blinker light wire via the flasher relay. Same as for the left. It all happens in the blinker/turn signal switch.

Check that both front running lights are lit, you may have a blown bulb or a problem with the wiring if the above is not evident.
 

·
Registered
Joined
·
371 Posts
Hey, all.

First-time motorcycle owner here. I've had a Rebel 500 since June. Love it. Already put more than 3,000 miles on the thing.

My turn indicator lights have been functioning normally, and then I come out of work the other day and the front right signal won't turn OFF. It's constantly solid. I click over to indicate a turn and it blinks as normal -- on off on off. When I cancel the turn, the light doesn't turn off, it goes back to solid.

The other lights on the bike appear to be functioning correctly.

Anyway, I'm trying to learn how to fix the motorcycle (first regular oil change coming up soon) and hope I can deal with this on my own.

Appreciate the help in advance. Thanks, all.
So you have had your bike for almost a year and are just now noticing the front running lights? Hopefully you notice the headlight is always on also! Like the others have said if only one front light is on with the key on, you most probably have a blown bulb. These are dual element bulbs where the signal may actually work but the running light function might be blown. The rear signals are only a single element bulb, as they perform only one function. You said you are also getting ready for your oil change at just over 3000 miles??? Hopefully you did the 600 mile break in service! You should get in the habit of doing a walk around inspection prior to riding so you'll notice things like bulbs being out (which this bike is actually known for), tire pressure, chain tension, oil level. Have fun riding!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Check that both front running lights are lit, you may have a blown bulb or a problem with the wiring if the above is not evident.
Guys, thanks a million. After reading that I'm a dummy who never realized both lights were always on I talked to a friend who introduced me to the wonderful world of dual filament bulbs! I never knew. One of the filaments blew on my left bulb.

Went out and grabbed a new bulb (2 for $2.97) and replaced it in the car parts parking lot. Good as new!

Thanks, y'all.
 

·
Registered
Joined
·
3 Posts
I'll second this, My second filament (running light portion) in my right turn signal went out at 7,000 miles, easy to replace, 1157 bulbs that are sold everywhere, screw on the bottom of the turn signal, remove the yellow housing, push the bulb in and twist to release... same as always... like Bogotahorrible above, my first thought was electrical problem assuming that there was only 1 filament in the bulb... I expect I'll be replacing them again with all the abuse these little bulbs get... good for another 7k
 
1 - 6 of 6 Posts
Top