Losing Trim Panels - Honda Rebel 300 & 500 Forum
 3Likes
  • 1 Post By JimInOz
  • 1 Post By Shanfara
  • 1 Post By Shanfara
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 07-15-2018, 08:23 PM Thread Starter
Senior Member
 
Shanfara's Avatar
 
Join Date: Jul 2018
Posts: 136
Losing Trim Panels

I keep having issues where my left trim cover falls off while riding and I have to order a new one. I have a third one now and my dealership said that they have seen this issue with several Rebel 5s. I cannot get the piece to hold towards the headlight. It is really frustrating and I am curious if anyone has the same issue and has figured out what is happening. In the meantime, I am going to throw a cotter pin on it.
Shanfara is offline  
post #2 of 8 (permalink) Old 07-15-2018, 08:32 PM
Senior Member
 
CueBaller's Avatar
 
Join Date: Mar 2017
Posts: 713
The rubber grommet where the front tab seats gets pushed in some times.

Make sure it's not pushed in before replacing the cover.

You should also hear and feel a distinct "click" when each of the pins and tab seats to indicate that it's properly fitted.

2017 Honda Rebel 500 - Black
CueBaller is offline  
post #3 of 8 (permalink) Old 07-15-2018, 08:41 PM
Senior Member
 
Kenny G's Avatar
 
Join Date: May 2017
Location: Robson Ranch, Denton, TX USA 2017 Rebel 500
Posts: 1,329
Garage
Cool

Quote:
Originally Posted by Shanfara View Post
I keep having issues where my left trim cover falls off while riding and I have to order a new one. I have a third one now and my dealership said that they have seen this issue with several Rebel 5s. I cannot get the piece to hold towards the headlight. It is really frustrating and I am curious if anyone has the same issue and has figured out what is happening. In the meantime, I am going to throw a cotter pin on it.
After you are sure that the rubber grommet is properly seated put just a little bit of wax, or any lubricant, on the pins before seating the cover.

Kenny G
Kenny G is offline  
post #4 of 8 (permalink) Old 07-15-2018, 09:02 PM Thread Starter
Senior Member
 
Shanfara's Avatar
 
Join Date: Jul 2018
Posts: 136
I used lithium grease and it never clicks. I lost a trim panel to trying to push too hard and it broke the tab. The grommet seams flush and in properly.

Sent from my Pixel 2 XL using Tapatalk
Shanfara is offline  
post #5 of 8 (permalink) Old 07-15-2018, 11:15 PM
Senior Member
 
Kenny G's Avatar
 
Join Date: May 2017
Location: Robson Ranch, Denton, TX USA 2017 Rebel 500
Posts: 1,329
Garage
Quote:
Originally Posted by Shanfara View Post
I used lithium grease and it never clicks. I lost a trim panel to trying to push too hard and it broke the tab. The grommet seams flush and in properly.

Sent from my Pixel 2 XL using Tapatalk
Make sure there is not a wire interfering with the cover seating.

Good luck.

Kenny G
Kenny G is offline  
post #6 of 8 (permalink) Old 07-15-2018, 11:32 PM
Senior Member
 
JimInOz's Avatar
 
Join Date: Aug 2017
Location: Melbourne - Australia
Posts: 308
Garage
JimInOz is offline  
post #7 of 8 (permalink) Old 07-16-2018, 12:17 AM Thread Starter
Senior Member
 
Shanfara's Avatar
 
Join Date: Jul 2018
Posts: 136
Excellent. Thank you folks. I am going to see if I can get it fitted up tomorrow.
Kenny G likes this.
Shanfara is offline  
post #8 of 8 (permalink) Old 07-16-2018, 10:33 AM Thread Starter
Senior Member
 
Shanfara's Avatar
 
Join Date: Jul 2018
Posts: 136
I had the main harness in the way, but it wouldn't budge. I just pressed the panel with a lot of force and it went in right. Finally. The whole falls off and wait weeks for a replacement dance has been old the last several months. Thanks y'all.

Sent from my Pixel 2 XL using Tapatalk
Kenny G likes this.
Shanfara is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Losing power temporarily NathanielCatch 2017+ Honda Rebel Issues And Problems 39 09-15-2019 07:10 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome