Hi from Romania - Honda Rebel 300 & 500 Forum
 3Likes
Reply
 
LinkBack Thread Tools
post #1 of 12 (permalink) Old 09-27-2018, 04:32 PM Thread Starter
Member
 
Join Date: Aug 2018
Location: Romania
Posts: 60
Hi from Romania

Hi guys,



I've been browsing the forum for a while. I have my Rebel 500 from mid July, did 1300km on it.

Here's a video with the bike


What I've added to it is all standard stuff from ebay and I've added it for looks:

- changed the brick and the back signals. Will change front signals too after i receive clamps, i have matching ones like the ones in the back;
- mussari exhaust;
- tank grips;
- screen protector;
- dart fly screen;
- headlight cover;

- gear indicator;


I need to change my front signals and add some fork boots. I'm waiting for some clamps to flip my mirrors and add a helmet lock on the handlebar. Currently I use a cord.



I removed the back seat and added 2 black plastic adhesive things for furniture. I can't believe they stick. I paid like 1 dollar for an A4 page full of them.

I removed the left passenger support all together and on the right just that small peg. Sometimes I remove the right support also together with the exhaust and I replace it with a radiant cycles small exhaust which doesn't need to be attached on the side.



Thanks for the help on the bring and other things I asked. Drive safe!
Kenny G and Gescutia like this.
Codrin Marius is offline  
post #2 of 12 (permalink) Old 09-27-2018, 04:58 PM
Super Moderator
 
01-7700's Avatar
 
Join Date: Apr 2017
Location: Maine
Posts: 1,053
Garage
Welcome !

Keith from Maine USA - Rebel R1
01-7700 is offline  
post #3 of 12 (permalink) Old 09-28-2018, 01:02 AM
Senior Member
 
WJMRTY's Avatar
 
Join Date: Jun 2017
Location: Melbourne Australia
Posts: 228
Garage
Welcome to forum n enjoy your ride
WJMRTY is online now  
post #4 of 12 (permalink) Old 09-28-2018, 08:57 AM
Senior Member
 
Join Date: Feb 2018
Location: Maryland, U.S.
Posts: 673
Garage
welcome
Odin is online now  
post #5 of 12 (permalink) Old 09-28-2018, 07:00 PM
Member
 
Rasko's Avatar
 
Join Date: Sep 2018
Location: Tri-State
Posts: 41
Garage
Hello fellow newbie!

Grant me the serenity
to accept the things I cannot change,
courage to change the things I can,
and wisdom to know the difference.
Rasko is offline  
post #6 of 12 (permalink) Old 09-28-2018, 08:23 PM
Junior Member
 
Join Date: Sep 2018
Location: Evergreen park IL
Posts: 2
Welcome
Gescutia is offline  
post #7 of 12 (permalink) Old 10-03-2018, 02:33 PM Thread Starter
Member
 
Join Date: Aug 2018
Location: Romania
Posts: 60
Thanks guys. I couldnt help it today and got the denali sound bomb.

My clamps to flip the mirrors arrived. Wrong size, i bought 7/8 and should have gotten 25mm. Ordered new ones.
Codrin Marius is offline  
post #8 of 12 (permalink) Old 10-04-2018, 06:00 PM
Senior Member
 
Robble10's Avatar
 
Join Date: Jul 2018
Location: Mid-Buckinghamshire, UK
Posts: 246
Who's gear indicator did you fit?
Robble10 is offline  
post #9 of 12 (permalink) Old 11-20-2018, 04:16 AM Thread Starter
Member
 
Join Date: Aug 2018
Location: Romania
Posts: 60
I got it from Ebay from Thailand, like 50 bucks. You find them if you search ebay, something like revashop.. I see that now many from the US just got them and resell with 100.



Works fine, but needs initial set up.
Codrin Marius is offline  
post #10 of 12 (permalink) Old 11-20-2018, 06:15 AM
Senior Member
 
Robble10's Avatar
 
Join Date: Jul 2018
Location: Mid-Buckinghamshire, UK
Posts: 246
Thanks. I have ordered one from Thailand which it says is 'plug and play'. Uses the diagnostic socket. We will see.

Just do it! (I did: 2017 Rebel 500; 2014 MT-07)
Robble10 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome